martes, 3 de marzo de 2015

DHCP Relay en el Cisco ASA

Las comunicaciones DHCP se realizan por broadcast y los mensajes broadcast no pasan a través de los routers. Por consiguiente, tanto las peticiones DHCP como las respuestas de los servidores no producen ninguna acción fuera de la red local. La solución mas fácil consiste evidentemente en poner un servidor DHCP en cada segmento de la red donde sean necesarios. Sin embargo, si se desea utilizar solo un servidor para varias redes, existe una solución , los agentes DHCP relay.

Un DHCP relay recibe las solicitudes de los clientes en formato de broadcast y las reenvía como unicast a la dirección del servidor DHCP.

Los mensajes unicast pueden pasar por los routers, llegando la información a buen puerto. En seguida, el servidor DHCP responderá con un mensaje en modo unicast con el agente relay como destino y este, a su vez enviara un mensaje broadcast que recibirá el equipo cliente. El cliente DHCP no sabrá que esta tratando con un agente relay, si no que piensa que hay un servidor DHCP real en su segmento.

Habilitar la función DHCP relay en el Cisco ASA.

Identificar el servidor DHCP
ciscoasa(config)# dhcprelay server ip-address interface

Si se tiene más de un servidor DHCP, puede repetir este comando para definir hasta cuatro servidores diferentes. En este caso, las solicitudes DHCP se transmiten a cada uno de los servidores de forma simultánea.

Identificar los clientes DHCP
ciscoasa(config)# dhcprelay enable interface

La palabra clave setroute instala automáticamente una ruta por defecto en el dispositivo.
ciscoasa(config)# dhcprelay setroute interface


CiscoASA(config)# dhcprelay server 20.1.1.2 DMZ
CiscoASA(config)# dhcprelay enable inside
CiscoASA(config)# dhcprelay setroute inside

Configurar la interface inside de los host para obtener la dirección IP por DHCP.
R1(config)#interface fastEthernet0/0
R1(config-if)#ip address dhcp 
R1(config-if)#no shutdown 
R1(config-if)#end
Interface FastEthernet0/0 assigned DHCP address 192.168.1.2, mask 255.255.255.0
R1#
R1#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.2     YES DHCP   up                    up      
FastEthernet0/1            unassigned      YES unset  administratively down down   

sábado, 21 de febrero de 2015

JunOS - Comandos Basicos

Ingresar al modo de “Operational Mode”.
root@% cli
Es este modo (Operational Mode) no vas a poder realizar ningún tipo de configuración en particular, se usa solo para ver configuraciones y monitorear el estado del equipo. Para ingresar a “Configuration Mode”.
root> configure
Entering configuration mode
root#
Ahora el prompt se muestra con un # al final, arriba podes ver entre corchetes tu ubicación (sumamente útil). Para ejecutar el equivalente a “show run” de CISCO existen dos opciones, desde “Operational mode”.
root> show configuration
Y desde “Configuration Mode”.
root# run show configuration

Establecer una password para el usuario root:
root# set system root-authentication plain-text-password
Configurar Hostname
root# set system host-name Juniper 

Mostrar interfaces o similar a show ip interfaces brief de Cisco.
root@Juniper# run show interfaces terse


Asignar una dirección IP a la interface em0
root@Juniper# set interfaces em0 unit 0 family inet address 192.168.10.1/30

Mostrar configuracion
root@Juniper# show

Borrar alguna linea de configuracion
root@Juniper# delete interfaces em0 unit 0 family inet address 192.168.10/30

Guardar configuración
root@Juniper# commit



Prueba de conectividad con un Ping
root@Juniper# run ping 192.168.10.2

Habilitar Telnet
root@Juniper# set system services telnet

Crear un Usuario y contraseña con class “super-user”:
root@Juniper# set system login user delfirosales class super-user authentication plain-text-password

Guardar cambios con commit

Dejar todo a los valores de fábrica
root@Juniper# load factory-default
root@Juniper# set system root-authentication plain-text-password
root@Juniper# commit

Servidor DHCP en el Cisco ASA

El Cisco ASA puede actuar como un servidor DHCP para distribuir dirección IP a los hosts finales que ejecutan servicios de un cliente DHCP. Esta característica es importante si usted tiene una pequeña sucursal que no posee un servidor DHCP dedicado. 


Para configurar el servidor DHCP a través de ASDM, ir a Configuración > Device Management > DHCP > DHCP server y seleccione la interface en la que desea habilitar los servicios DHCP.



Para configurar un ASA como un servidor DHCP, desde la línea de comandos.

Configuramos la interface inside.
CiscoASA# configure terminal
CiscoASA(config)# interface gigabitEthernet0 
CiscoASA(config-if)# nameif inside
INFO: Security level for "inside" set to 100 by default.
CiscoASA(config-if)# ip address 192.168.1.1 255.255.255.0
CiscoASA(config-if)# no shutdown 

Definir el conjunto de direcciones IP y asignar el pool a los usuarios internos.
CiscoASA(config)# dhcpd address 192.168.1.10-192.168.1.30 inside

Habilitar el servicio de servidor DHCP en la interface
CiscoASA(config)# dhcpd enable inside

Definir el nombre de dominio para los clientes DHCP.
CiscoASA(config)# dhcpd domain delfirosales

Definir un servidor de nombres de dominio (DNS.
CiscoASA(config)# dhcpd dns 192.168.1.50

Tiempo de concesión en segundos. El valor predeterminado es de 3600 segundos (1 hora).
CiscoASA(config)# dhcpd lease 7200



Para comprobar la configuración de DHCP, podemos utilizar el comando show dhcpd state para mostrar el estado actual de DHCP en  las interfaces internas y externas. El comando show dhcpd binding para visualizar los enlaces actuales de los usuarios internos y el comando show dhcpd statistics para mostrar las estadísticas de DHCP.

CiscoASA# show dhcpd state    
Context  Configured as DHCP Server
Interface inside, Configured for DHCP SERVER

CiscoASA# show dhcpd binding
IP address       Client Identifier        Lease expiration        Type
   192.168.1.10  0063.6973.636f.2d63.           7020 seconds    Automatic
                 3830.302e.3037.3734.
                 2e30.3030.302d.4661.
                 302f.30


Para borrar los enlaces de DHCP o estadísticas, utilice el comando clear dhcpd binding o clear dhcpd statistics.

CiscoASA# clear dhcpd binding
CiscoASA# clear dhcpd statistics